Author Topic: Unusual tool paths  (Read 2226 times)

Offline NITROCHUCK

  • Ewok
  • *
  • Posts: 8
    • View Profile
Unusual tool paths
« on: December 29, 2018, 02:48:10 am »
This is probably just a setting but profile cut of a three letter dxf has some unusual tool paths...big arcs that stay in contact with the work....
Sim in video is doing exactly what code is telling it to...
https://youtu.be/X0dBPmp-UwI

Offline Bubba

  • CNC Jedi
  • *****
  • Posts: 3247
    • View Profile
Re: Unusual tool paths
« Reply #1 on: December 29, 2018, 03:54:30 am »
Don't know anything about you machine controller, but I bet it has something to do with absolute and incremental setting in your post.. Wish could offer more advice than that. Good Luck.
My 2ยข

Win10 (64 bit, CB(1.0)rc 1(64 bit) Mach3, ESS, G540, Endurance Laser.

Offline NITROCHUCK

  • Ewok
  • *
  • Posts: 8
    • View Profile
Re: Unusual tool paths
« Reply #2 on: December 29, 2018, 03:56:43 am »
The large arcs are definitely rapids.... meant to be at clearance Z so they don't cut...just don't know what setting in CamBam I have wrong....

Offline NITROCHUCK

  • Ewok
  • *
  • Posts: 8
    • View Profile
Re: Unusual tool paths
« Reply #3 on: December 30, 2018, 02:52:48 am »
Nope... issues weren't in the code or my machine. ..Sim was set wrong ...arc start and stops with generated code worked perfectly in the mill !!!

Offline lloydsp

  • CNC Jedi
  • *****
  • Posts: 8664
    • View Profile
Re: Unusual tool paths
« Reply #4 on: January 01, 2019, 15:52:48 pm »
Hooray, Nitro!

We like it when it's NOT CB misbehaving! <grin>

Lloyd
"Pyro for Fun and Profit for More Than Fifty Years"

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1872
    • View Profile
    • pixelmaker
Re: Unusual tool paths
« Reply #5 on: January 01, 2019, 18:12:57 pm »
These arcs are created when the control cannot process the amount of decimal places and the small arcs that CamBam outputs. There's a lot of scrap on the market for hobby controls.
The easiest way to solve the problem is to set the values in Cambam's postprocessor.
Go to the options of the postprocessor you are using.
Find the "Minimum arc length". The default value is 0.0001. Change this value to 0.001 or, if the arcs still appear, to 0.01.
Under number format, the default is 0.0###
Change this value to 0.0## .
Then you have to save the postprocessor and try again.

Alternatively, you can check the controller to see if you can change the values for the smallest arc there

ralf