Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Tool-n-Around

Pages: 1 ... 8 9 [10] 11 12 13
136
CamBam help (General usage) / Re: Cant believe this one has me stumped.
« on: August 26, 2021, 22:27:21 pm »
Sorry I answered in the other thread. ::)

Got it. Thanks for that. I have a slightly different version of UGS but all the same features, just organized a bit differently. However, I've bee primarily using GRBL Machine.

With your file, the short answer is I don't know.

It does appear to have just been the fact that I only entered the tool diameter and left the tool number at default 0. When I created a new tool and assigned that number (well any number except 0), it ran exactly as expected.

On tool changes, for now I'm content to create separate programs, but I will come back to it in time. I have a lot of hardware related things to address to get the machine performance where it needs to be.

One thing that is driving me absolutely out of my skullis an unresponsive computer mouse. I was convinced it was EMI but now I'm not so sure.  It only occurs when the USB cable is connected to the controller. I don't think it is radiated emission, maybe conducted, but maybe even a RAM issue. I cant get any mouse to reliably work. Not touch pad, BT, or even an old hard wired mouse. I literally have to hold the computer in my hand and sometimes grab the USB cable to get response. I've tried ferrite beads, shielding, about every imaginable combination of grounding, and it still persists.

Best,
Kelly

137
Well, despite best efforts, I blew up a piece of phenolic stock. Posting this for feedback on whether I have diagnosed the problem correctly and to avoid recurrence.

I experimented on some small pieces with feed rates and found with a .25” 2-flute spiral bit, 30in/minute at .125” depth of cut to be about the max for this phenolic stock. Even that could produce a little chatter on the initial plunge but once it was cutting on side, it cut well. I even cut a sample piece of foam to try to de-risk the cut in phenolic stock.

I did rotate the part so I could set it up on the spoil board I had been working with. I cut the port passages with 2 passes at .1” and a final pass at .050” so the floor would have a decent finish. The roughing clearance cut was originally .015” and in what turned out to be poor judgement, I decided to increase the roughing clearance to .025”, and then I made a full depth cut (.25”) and .025” clean up on the profile.

Now, if I was a little more experienced, I may have thought oh, that  feature not being roughed out is going to be a problem on the next clean up pass and stopped the program, but I thought it was just a strange affect caused by optimization. It wasn’t.

Apparently, the problem was caused because the increase to .025” per side roughing clearance reduced the distance between the central boss and the plenum profile to just less than the .25” cutter diameter. I didn’t notice this on the foam trial piece but this appears to have caused the program not to cut the initial roughing passes between these features and then, when the program called for the full depth finish cut, the additional .050” clearance opened the clearance to greater than the cutter diameter and the program did at commanded and plowed through that area at full .25” depth and lost a bunch of steps (like over .25” worth) and then proceeded to plow through a number of other features at full depth until I got my hand on the stop button, but the part was scrap, but was otherwise looking perfect to that point. I went back and looked and this didn’t happen in simulations when the roughing clearance was .015” instead of .025”. So I measured the clearance in the model and sure enough it was .29x” t- .300”, so I closed the clearance down just enough for it to be fatal. -Sighhhh. At least nothing broke.

So I’ll have another go, but to avoid such problems in the future, how much clearance to bit diameter is enough as far as the program goes? I seen that a .25” cutter won’t drill a .25” hole, but will CB drive a .25” cutter through .25” openings? And if I watch each MOP in simulation and it cuts a path with narrow clearance, should I expect the same when run though the controller?

-Still learning.  :)

Best,
Kelly

138
CamBam help (General usage) / Re: Cant believe this one has me stumped.
« on: August 26, 2021, 01:58:10 am »
Try making the tool number "1".  Some machines get a bit bitchy about tool-number zero. Lloyd
Many thanks Lloyd that did it. Note to self, put some effort into creating a real tool library instead of just adhoc adds to the default, and call out tool numbers (no zero), and not just tool diameter.
BTW, K, To save wear and tear, don't actually cut the plate again, until you see the pattern work.  Just jack the cutter up (or remove it), and let the router "do it's thing", without actually cutting anything. You MIGHT want to try that, first, with your existing code.  It could be that there's a 'near overload' cutting 0.7" wide with a 1" cutter, and the router itself might be shutting down.  IF it goes through the whole pattern while NOT under load, you might suspect that. In that case, a narrower cutter could solve the problem.  Reducing the feed rate and increasing RPMs are other ways to address it. Lloyd
After the first two times I was just cutting air. I don’t think there was any overload……Although the program was set at .050” it was only cutting half that in MDF.
There is an easier way I use all the time. Draw 1 line at the edge of the board. Use a profile cut with the cut width a little larger than the board and set cutting direction as mixed. The cutter will zigzag back and forth until its done.
Hmmm. I’ll try that too. Thanks Gary.

Best,
Kelly

139
CamBam help (General usage) / Re: Cant believe this one has me stumped.
« on: August 25, 2021, 20:23:23 pm »
Try making the tool number "1".  Some machines get a bit bitchy about tool-number zero. Lloyd



Thanks Lloyd. Will try that a little later on this evening.

Best,
K


140
CamBam help (General usage) / Cant believe this one has me stumped.
« on: August 25, 2021, 19:43:23 pm »
Seems like the simplest program possible so after running a half dozen parts successfully, a bit humbling to be shot down by this one. It's just surfacing a 24" x 12" spoil board with a single polyrectangle and pocket MOP. The program simulates and appears to run fine but doesn't complete the machining even though it always reports program completion in the message line.

Tried two similar programs but same result....program finishes but the pocket isn't completely machined. Oddly, it seemed to surface a little more of the board when I ran it successive times but never completed, and the portion that was machined wasn't centered. The post processor is the grbl post Dave B modified for me. I didn't try another post.

Scratching my head.

Best,
Kelly

141
CamBam help (General usage) / Re: Second Post, Second Project, Some Qs
« on: August 24, 2021, 14:04:56 pm »
Thanks fellas. Not sure I would have gotten there without your help but feeling much more confident and comfortable now and have used it for many related small tasks.

I discovered many opportunities for improvement on my router hardware. I realize it's a hobby rig but I was actually very disappointed with a number of things on the hardware. I think the linear motion hardware is ok, but the ability to actually realize the potential positional accuracy is quite low. The plasma table under under the spoil board is so horribly out of square it's near impossible to mount the rail/gantry system squarely. Best I could get was .015" over 18". I'm not satisfied with that. The provisions for mounting the spoil board were poorly thought through. The z-axis and router mount unnecessarily conceded a lot of rigidity. Not a big deal for cutting foam, but will be for harder materials. The z-axis must be disassembled to remove the router mount. The stepper and homing switch cables are unshielded (and the related EMI issues took several days from me) and will need to be replaced, and about a half a dozen other annoying things.

I have a fairly generous available envelop for my typical projects and will set up a few work locations and a vice at different table locations, but also need to test the accuracy and repeatability of the homing switches

It's all correctable and I will do so in time. I've found the state of tune of one's equipment always says something about the owner. I guess it's like any other machine in regard to needing to be set up and dialed in properly but the provisions for doing so could be much better.

On CAM software, I originally thought I'd bite the bullet and learn and become proficient in solid modeling and related CAM packages but I was wrong on that......I suspect 90%+ of my near term needs can probably be met with CamBam and it's much quicker and easier to learn and perform those tasks with CamBam. I've never experienced a user forum as responsive and helpful as this one. By comparison, the support from the machine manufacture and that forum was Nil. Not sure I would have gotten there without the post processor mod that Dave wrote.......it just works.

Best,
Kelly

142
Cut my first parts today with success. Results here:

https://cambamcnc.com/forum/index.php?topic=9262.msg72543#msg72543

I decided to cut the air filter base and lid first because the foam stock is 50 cents and the Phenolic/Bakelite composite stock $50, so I figured a little experience under the belt would be wise......but this part is next!

Best,
Kelly

143
CamBam help (General usage) / First CNC Parts - Automotive Air Filter
« on: August 23, 2021, 21:58:22 pm »
I cut the air filter patterns today. These are foam patterns to be cast in aluminum via lost foam method. Everything came off well except on the first run, the 2 1/2" vacuum hose shifted, activated the z limit switch, and stopped the program due to soft limit error. For the life of me, I couldn't get the controller out of idle state afterward. I ended up having to shut down, re-home, dial in the work origin, and start the program again. I did break the parts/MOPs up as tool changes were required. The top of the lid required four tools; the rest between one and three. Many thanks for all the help. Nice to have good results.......keeps the learning enthusiasm high.

Best,
Kelly

144
Scripts and Plugins / Re: Gcode by part name V2.2.0.0
« on: August 20, 2021, 14:48:10 pm »
I can download and use from post #1 but when I went looking for this one on the plugins list I couldn't find it. I remembered it mentioned and linked in one of my posts.

http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/EntityReplace.html

Is it there? There under a different name? or not yet released to the plugins list?

I intend to use it to allow me to make tool changes.

Best,
Kelly

145
Anyway there are benefits from having different co-ordinates at the drawing and part levels when doing more complex work involving having fixtures or maybe a couple of vices and a 4th axis or like here a work holding chuck that has to be indicated in then used then removed again. most people may never use this facility.

Thanks for the example. I understand.

...I'm just starting to have a look at your file Perimeter Profile Part. The only thing I can see is using a starting leadin in the outside space mop I've selected spiral leadin here. This helps the witness mark that you can get with lightweight routers  when using no leadin.

Was wondering about the lead in. So far I’ve only been cutting foam so not much of a challenge to even the little router or rattle the router bit. The phenolic composite for the spacer is supposed to be the most free machining variety but is quite a bit harder than hard wood. The only other place I might use a lead in for the same reason are the bores. When is lead out beneficial?

The red I was seeing earlier was that port path had already machined away 0.25 of the Bore Pockets tool paths already and so set the Bore Pockets Stock Surface to -0.125........In the sim pic of this original file that there is a sea of red moves, these are G0's meaning that the machine is moving about the work piece without doing any cutting, for efficiency's sake this is bad. I would before smashing the start button, make some test runs on a piece of excess or left over stock material to get a feel for the feedrate that your machine is happy with, before committing to the stock.

This was my first cb part and I was having difficulty trimming at the intersection of the bores and port path, so I merged them and cut them altogether and then had to go back and machine the remaining 1/8” of bore depth through. The stock thickness in the file says 1” but the actual part is only 3/8” thick. I had turned off all the cb optimization because I wanted to see the ops in order while I was getting errors, and also because I wanted to insure the perimeter was cut last and the guide slots after the port path.

I made a new file that is more efficient Gcode.....

Thank you very much for those. I downloaded them and took a quick look in cb. Looks like it doesn’t recognize the MOP Trochopock (unknown MOP Type) and missing some styles ‘Aluminum Drill and Mill” and ‘FeedRateAdjuster’, and also Tool Index (32) not found. I will look them over more closely a little later. I know I’ve read about tool paths for stock removal but couldn’t find that section on first glance.

One thing to mention is that the sim times are (for various reasons) a bit iffy, ……..The sim time in Mach3 was 1 hour and 32 minutes for the troc file and you still have to take this answer with a grain of salt and is only an estimate. the original file simed at 2 hours 24 minutes.

Ya-know, when I did the air cut, I don’t think it was anywhere near that long. 30-45 minutes, but, I backed the feedrates down from 120in/min to 60 in/min and cant remember if that was before or after the air cut.

As time permits I'll apply those as well to this posted file once you work out you maximum feedrate at maximum depth that your machine is comfortably capable of, this is the figure the troc mops and the feedreate adjuster need and it must be reasonable accurate which you'll have to obtain by trial and error to some degree.

I don’t have any experience with this little router. All my other router motors on my pin router are 3.5HP. Also, not much experience with the phenolic composite, so will be conservative. This a one-time part (though there may be other similar parts) unless I scrap it, so even though optimization isn’t that critical, it’s still good to learn early and on a familiar part because it will become a factor, and 50% reduction in run time isn’t a trivial gain, especially when I get to more complex parts.

I’ve been doing a lot of fine tuning to my hardware, software maintenance, downloading and playing with some plug ins, and just generally tidying things up. I also order stock and some parts. Hopefully I’ll complete all that the remainder of the weekend and get cutting. Thanks for all your help Dave. It is sincerely appreciated.

Best,
Kelly

146
Installation Help / Re: Maintaining Multiple Instances of CB.
« on: August 11, 2021, 14:16:41 pm »
Great!.....and thank you.

Best,
Kelly

147
Installation Help / Maintaining Multiple Instances of CB.
« on: August 11, 2021, 13:37:16 pm »
I have a dedicated computer in my shop and another I spend most of my time on. As far as cb, the shop computer is primarily used to run the CNC machine and the other to draw and create files. My administrative skills are modest so I was just wondering what is best practice for maintaining two separate instances of CB.

As far as various cb settings, I could see how I may actually want different settings on the shop machine, so my question is primarily in regard to plugins. I figure I can just keep a running file of all the downloads to keep track of what has been installed over time, but given the different installation procedures for various plugins, is there anyway to replicate all plugins on another cb instance other than installing them one at a time?

Best,
Kelly

148
CamBam help (General usage) / Re: Second Post, Second Project, Some Qs
« on: August 11, 2021, 13:03:40 pm »
...haha there is a chamfer plugin as well. its a good source of ways to do stuff easy. fillet-chamfer  http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/fillet-chamfer.html take a look at what we got http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/plugin_menu.html

I have installed and used a couple plugins but this morning I spent some time looking at what is available and reading about their function. Wow that's quite the list. I saw several that I wished I had downloaded before my last drawing projects. With a better awareness of what's available, I won't hesitate to add them as needed.

Best,
Kelly

149
Scripts and Plugin Help / Re: feedback to text file
« on: August 11, 2021, 12:42:21 pm »
Hi David, will this plugin copy the text as displayed in the GRBL Machine plugin message window?

Best,
Kelly

150
If you place some numbers in there, and click back into the cb screen a red cross should appear (you can move it anywhere including 0,0,0 )

Yes, I understand and have done so, but I only set the Machining Origin at the top level Machine folder. Machine origin also appears at each part level which I have left at default which is NaN. So since the files run fine I assume the top level governs unless a different Machine Origin is set at the part level, but not really sure why one would want to do so.

Kelley number 3 is a tin of worms....

I'll take your advice on that. I originally thought it was EMI issue because I would set my lap top on the CNC machine waste board and the touch pad would then become totally inoperable.......but it was of course also tethered to the controller by the USB cable, and it now appears that is really the source of the problem.

I do have a dedicated computer for the shop. I have cb installed on my everyday lap top. Since I was using UGS on the shop computer, I was just transferring gcode files on a thumb drive. Now that I have installed GRBL Machine plugin, I'm toting my every day lap top back and forth to the shop. I need to install cb on the shop computer but didn't want to maintain two instances while I'm in the steep learning phase.

I would have suggested that you re-flash the firmware with GRBL Ver1.1 or maybe my 5Axis version of GRBL, But the manufacturer may have adjusted the firmware (to maybe re-assign pins)  to suit their particular build practices. So I thought better of saying anything.

My computer administrative skills are also modest so probably wise to keep it simple for now, do some 2D machining, learn as I go and enjoy the benefits.

Best,
Kelly

Pages: 1 ... 8 9 [10] 11 12 13