Author Topic: Lathe turning using CamBam plus 1.0 and Mach 3  (Read 310 times)

Offline Practice Makes Better

  • Ewok
  • *
  • Posts: 3
    • View Profile
Lathe turning using CamBam plus 1.0 and Mach 3
« on: September 26, 2022, 12:05:47 pm »
Hello, when I run my lathe code in Mach 3 the lathe cuts from left to right and at the end of the code the lathe tool advances to the center of the lathe chuck; what am I doing wrong?

Offline dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 7048
    • View Profile
    • Cambam V1.0 French Doc
Re: Lathe turning using CamBam plus 1.0 and Mach 3
« Reply #1 on: September 26, 2022, 13:27:25 pm »
Hello

Are you sure that the axis are defined in the right direction in Mach3 ?



If it is OK, for the X axis, you also have a setting in Mach3 to select front or rear turret. (see picture)

For Z, be sure that in the machining operation " lathe cut direction" is "right hand"

please, share your CamBam file so we can check it ;)

++
David
« Last Edit: September 26, 2022, 14:17:19 pm by dh42 »

Offline Practice Makes Better

  • Ewok
  • *
  • Posts: 3
    • View Profile
Re: Lathe turning using CamBam plus 1.0 and Mach 3
« Reply #2 on: October 04, 2022, 00:44:53 am »
Hi David, thank you for your quick reply much appreciated, I checked my X and Z axis, they are setup properly I suspect the problem is in the GCode. I am sending you a copy of my program file and GCode; I would appreciate your input.

Offline dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 7048
    • View Profile
    • Cambam V1.0 French Doc
Re: Lathe turning using CamBam plus 1.0 and Mach 3
« Reply #3 on: October 04, 2022, 12:38:42 pm »
Hello

I will have a look later, but what I see immediately is that you forgot to select a lathe post processor ; maybe it is the problem ?

Edit:

Ok that works

In CamBam:

- 1) you must change the value for clearance plane for both mops, it must be > to the stock surface (I set it to 10) ; if not, the tool retract in the wrong direction and hit the workpiece !

- 2) For both mops, you must select a lathe tool profile.

- 3) you must select the Mach3-turn post processor and check for some settings in it

* "invert arcs" must be set to false
* "lathe X mode" must be set to radius

In Mach3, use front turret and radius mode.


++
David
« Last Edit: October 04, 2022, 13:42:36 pm by dh42 »

Offline Practice Makes Better

  • Ewok
  • *
  • Posts: 3
    • View Profile
Re: Lathe turning using CamBam plus 1.0 and Mach 3
« Reply #4 on: October 05, 2022, 00:43:18 am »
Dave your files and your advice helped immensely, Mach 3 and the lathe seemed to be working perfectly much appreciated, all my best!