Author Topic: Font size in interface  (Read 2369 times)

Offline onekk

  • CNC Jedi
  • *****
  • Posts: 521
    • View Profile
Font size in interface
« on: September 05, 2015, 16:56:44 pm »
Please add some controls to modify the font size of the interface, on Linux mono application are shown with a small font difficult to read and seems there is no controls to modify them with mono.

TIA and Regards

Carlo D.
onekk
Carlo D. (onekk)

eShapeoko #343 750x1000 mm + GRBL + bCNC + CamBam

Offline mrdunk

  • Ewok
  • *
  • Posts: 4
    • View Profile
Re: Font size in interface
« Reply #1 on: December 31, 2021, 14:39:34 pm »
This is an old post but it's still an issue for me.
For some reason Mono does not match my system default font and widget size.
I'm running Ubuntu 20.04.3 LTS.
I presume anyone using a Gnome based desktop environment will have similar issues.

From a little reading online, I think this is an issue with Mono rather than CamBam
so from a philosophical standpoint, it would be better addressed by the Mono developers.

On the other hand, the Mono community does not appear to be addressing it so it would be great to see a fix in CamBam.

There are already "Menu Font Family" and "Menu Font Size" options to alter the top menu bar size.
Similar options for fonts used elsewhere would be great.

An option to scale widget size would be nice too but just bigger fonts would be adequate.

Offline mrdunk

  • Ewok
  • *
  • Posts: 4
    • View Profile
Re: Font size in interface
« Reply #2 on: December 31, 2021, 14:46:48 pm »
I put my current workaround for this issue on the Linux page in CamBam's main documentation page:
https://cambamcnc.com/ref/ref.linux#cmt_link202

Pasting the relevant part here:

Use a xpra session to run CamBam and connect to it locally.
The "run_scaled" script at https://github.com/kaueraal/run_scaled wraps xpra nicely.
The following worked for me:

Code: [Select]
(cd ~/CamBam1.0/ && wget https://raw.githubusercontent.com/kaueraal/run_scaled/master/run_scaled)
sudo chmod +x ~/CamBam1.0/run_scaled
sudo apt install xvfb xpra x11-xserver-utils

Start CamBam with something like:

Code: [Select]
~/CamBam1.0/run_scaled --opengl=no --scale=1 ~/CamBam1.0/cambam.shor
Code: [Select]
~/CamBam1.0/run_scaled --scale=1 ~/CamBam1.0/cambam.sh(Use which ever looks nicer on your system.)

Note that you pass "--scale=1" to the script so it launches CamBam at the default size.
Now you can scale the whole window using the little green "xpra" icon in the top toolbar.

Picture -> Scaling -> 125%