Author Topic: Plugin Website  (Read 849 times)

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1870
    • View Profile
    • pixelmaker
Plugin Website
« on: August 24, 2021, 11:22:24 am »
David
Can you please update the link to the forum on the download page of the new V-Engrave plugin.
It still goes to the old forum structure

Many thanks to the programmers who have done a very good job

ralf
« Last Edit: August 24, 2021, 11:25:54 am by pixelmaker »

Online dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6932
    • View Profile
    • Cambam V1.0 French Doc
Re: Plugin Website
« Reply #1 on: August 24, 2021, 15:27:31 pm »
Hello Ralf

I don't understand, the link still fall on this thread  ???

++
David

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1870
    • View Profile
    • pixelmaker
Re: Plugin Website
« Reply #2 on: August 24, 2021, 17:21:37 pm »
Hello David
under the link to the new V-engrave plugin is the link
http://www.cambam.co.uk/forum/index.php?topic=3513.0
The URL is changed by the redirect to
https://cambamcnc.com/forum/index.php?topic=3513.0/index.php.  I only get a white page due to the attached "index.php"
If I delete the attached "index.php", I get the page. Perhaps this is also due to an incorrect instruction for reformatting the links via htaccess. I don't know how the redirection is structured.
I get the same problem in Safari and in Firefox, both are the latest versions

ralf
« Last Edit: August 24, 2021, 17:28:57 pm by pixelmaker »

Online dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6932
    • View Profile
    • Cambam V1.0 French Doc
Re: Plugin Website
« Reply #3 on: August 24, 2021, 18:20:42 pm »
Strange, here, both links gives the same result  ???

Is this better now ?

++
David


Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1870
    • View Profile
    • pixelmaker
Re: Plugin Website
« Reply #4 on: August 24, 2021, 20:37:38 pm »
no, the link still has the index.php at the end
All links that go to the old server "cambam.co.uk/forum" are formatted incorrectly.
This also affects all links on my german plugin page that still point to the old domain.
I assume that the redirection is done via .htaccess. There only links with www. are reformatted and there must be the error.
This .htaccess is probably in the root directory of the old forum.
If you can't get to the .htaccess file, I'll have to change all the links too.
This is then a pain to change all the links to the new domain.

ralf

Online dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6932
    • View Profile
    • Cambam V1.0 French Doc
Re: Plugin Website
« Reply #5 on: August 24, 2021, 20:57:28 pm »
currently the link in the plugin site is:

https://cambamcnc.com/forum/index.php?topic=3513.msg22814
(it is the address of the first post of this thread)

I replaced it by:

https://cambamcnc.com/forum/index.php?topic=3513.0

(it is the address of the topic itself and I just copy it from the address bar) .. have a retry

Quote
If I delete the attached "index.php", I get the page.

the second or the first ?

the first index.php is present in all pages of the forum for me, even when I click on the CamBam logo at the top/left side of the forum

Quote
If you can't get to the .htaccess file, I'll have to change all the links too.

No, I've no access to the files of the forum

Other persons have the same behavior than Ralf with the link ? for me all combinations works, even without the first index.php as following:

https://cambamcnc.com/forum/?topic=3513.0

++
David
« Last Edit: August 24, 2021, 21:13:20 pm by dh42 »

Offline lloydsp

  • CNC Jedi
  • *****
  • Posts: 8659
    • View Profile
Re: Plugin Website
« Reply #6 on: August 24, 2021, 21:30:38 pm »
It works fine for me, David.  Any one of the three contexts works.

Lloyd
"Pyro for Fun and Profit for More Than Fifty Years"

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1870
    • View Profile
    • pixelmaker
Re: Plugin Website
« Reply #7 on: August 25, 2021, 11:04:23 am »
It seems to only affect links from outside the server.
They will be redirected to the new server and the domain will be reformatted.
From http://www.cambam.co.uk/forum/index.php?topic=3513.0
will then still be
https://cambamcnc.com/forum/index.php?topic=3513.0/index.php
The "/index.php" at the end is wrong.
The error only occurs when domains "www.cambam.co.uk/forum" are converted to "https://cambamcnc.com/forum/". An "index.php" is appended to the end of each link. This is of course wrong.
Links that do not begin with "www" are not converted at all.
I am now starting to replace all the links on my plugins page with the new nativ domain.
Users have pointed out to me that it doesn't work for them either.

@David: Please can you move these posts to another forum, I don't want to keep hijacking this thread.
ralf
« Last Edit: August 25, 2021, 11:06:03 am by pixelmaker »