Author Topic: [V1 - 22] Backface milling in 3D MOP no longer works (solved in V1 RC1)  (Read 2852 times)

Offline dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6013
    • View Profile
    • Cambam V1.0 French Doc
Hello

It seems that the Backface milling is no longer working in V1.0 (tested on R16)

Also, even in the previous version (0.98P), backface milling works only with the top of the object at Z=0 ; if we works with the bottom at Z=0, the toolpaths are wrong.

++
David
« Last Edit: November 01, 2019, 22:03:58 pm by dh42 »

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1746
    • View Profile
    • pixelmaker
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #1 on: October 21, 2018, 13:40:26 pm »
Quote
Backface milling is no longer working
http://www.cambam.co.uk/forum/index.php?topic=3658.0

This is the same heavy bug that exists since version 0.9.8.P. It never works since this.

I have just tested again and see no difference between the frontside/ backside milling of z constant toolpaths or waterline toolpaths. Nothing works.
Even if I align the top side of the object at Z=0, no toolpaths are created for the back side. All toolpaths are only from the front side.
I've been used to turning the object around since 0.9.8P, so it didn't occur to me that this has changed for the worse.

ralf
« Last Edit: October 21, 2018, 14:03:18 pm by pixelmaker »

Offline dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6013
    • View Profile
    • Cambam V1.0 French Doc
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #2 on: October 22, 2018, 00:30:28 am »
Hello Ralf

Yep, it's worst in 1.0 than in 0.98 ... not usable at all in 1.0 :'(

Quote
I've been used to turning the object around since 0.9.8P, so it didn't occur to me that this has changed for the worse.

Yes, not easy to remember all what must be tested on each new version !, and I rarely use 3D machining and even more rarely the back side functions for my use.

++
David
« Last Edit: October 22, 2018, 00:34:23 am by dh42 »

Offline Bob La Londe

  • CNC Jedi
  • *****
  • Posts: 3943
  • ^ 8.5 pounds on my own hand poured bait.
    • View Profile
    • CNC Molds N Stuff
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #3 on: October 24, 2018, 15:01:14 pm »
I had not realized this was a bug or lost feature.  I just thought I forgot how to do it.  

When I design a mold I build a positive (casting) and then use a Boolean subtract to remove it from a block to create the mold.  That is what I export from CAD to import into CamBam to do the CAM work.  

However, sometimes I get an STL file from a customer, and the only practical and efficient way to make a mold from it is with backface.  Its not a tool I use very often, but it is an important tool.  Sometimes its the only practical and efficient way to do the job.  


« Last Edit: October 24, 2018, 15:11:53 pm by Bob La Londe »
Getting started on CNC?  In or passing through my area?
If I have the time I'll be glad to show you a little in my shop. 

Some Stuff I Make with CamBam
http://www.CNCMOLDS.com

Offline Bob La Londe

  • CNC Jedi
  • *****
  • Posts: 3943
  • ^ 8.5 pounds on my own hand poured bait.
    • View Profile
    • CNC Molds N Stuff
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #4 on: October 25, 2018, 01:10:27 am »
What was the last release where it worked properly? 
Getting started on CNC?  In or passing through my area?
If I have the time I'll be glad to show you a little in my shop. 

Some Stuff I Make with CamBam
http://www.CNCMOLDS.com

Offline dh42

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 6013
    • View Profile
    • Cambam V1.0 French Doc
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #5 on: October 25, 2018, 02:04:41 am »
Hello

I don't know ; on 0.98 P it works only in certain cases (depending of the Z position of the object) ... I don't remember if it has worked properly on older versions.

++
David

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1746
    • View Profile
    • pixelmaker
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #6 on: October 25, 2018, 09:17:52 am »
Quote
I don't know ; on 0.98 P it works only in certain cases

0.9.8P works fine for me.
Both if the objects are centered in Z-direction as well as top and bottom. Then you only have to set the mirror plane with "Backside Z 0".
I did not install the old versions 1 anymore.

ralf

Offline EddyCurrent

  • CNC Jedi
  • *****
  • Posts: 4383
    • View Profile
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #7 on: October 25, 2018, 16:15:28 pm »
To avoid possible confusion and /or errors I would rather rotate the object myself and create a MOp for it as normal.
Made in England

Offline Dragonfly

  • CNC Jedi
  • *****
  • Posts: 2314
    • View Profile
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #8 on: October 25, 2018, 16:34:24 pm »
Some models might have a flat bottom and rotation will not work.

Offline pixelmaker

  • CNC Jedi
  • *****
  • Posts: 1746
    • View Profile
    • pixelmaker
Re: [V1 - 22] Backface milling in 3D MOP no longer works
« Reply #9 on: October 26, 2018, 10:26:22 am »
I think it's the same whether I rotate a toolpath around an axis at a certain Z-height or whether I rotate an object.
With back side milling in CamBam, only possible up to 0.9.8P, also only one pivot point is calculated.
The disadvantage is that you have to have the 3D object twice in the file if you want to archive it.

ralf