Author Topic: Linux installation questions  (Read 316 times)

Offline Gruber

  • Ewok
  • *
  • Posts: 2
    • View Profile
Linux installation questions
« on: March 26, 2020, 08:02:47 am »
Hello,

i would like to try your software and have this platforms:

- notebook with linux mint 19
- raspberry pi with latest rasbian

On the notebook i have the problem that there is already a mono-devel installation (mono-devel 4.6.2.7+dfsg-1ubuntu1). I suppose cambam doesnt work with this version? If not, can i install the actual mono-devel version 6.* without breaking things?

Will the new Cambam software work on my raspberry PI 4 with the latest rasbian version?

best regards

Offline 10bulls

  • Administrator
  • CNC Jedi
  • *****
  • Posts: 2150
  • Coding Jedi
    • View Profile
    • www.cambam.info
Re: Linux installation questions
« Reply #1 on: March 26, 2020, 09:45:54 am »
CamBam should work with mono 4.6 ... it is worth trying it first.

http://www.cambam.info/ref/ref.linux

Upgrading to a later mono version can be disruptive, but it depends on what other mono based programs you are using.  Generally I find keeping mono up to date fixes more problems that it causes.
If you can, I recommend removing any mono runtimes and packages first, then installing newer versions.
http://www.cambam.info/ref/ref.linux#dependencies

CamBam works great on my raspi 4.
Still only using GDI graphics modes currently, but have been looking at getting OpenGL ES working with it.

Good luck!


Offline Gruber

  • Ewok
  • *
  • Posts: 2
    • View Profile
Re: Linux installation questions
« Reply #2 on: March 26, 2020, 13:45:30 pm »
Thank you for the info. I will try with my raspberry PI 4 then.