Author Topic: Crash when Draw Text is selected - Solved !  (Read 575 times)

Offline llamatrails

  • Ewok
  • *
  • Posts: 49
    • View Profile
Crash when Draw Text is selected - Solved !
« on: October 12, 2020, 01:16:11 am »
I have had the Windows 64bit version 1.0 installed and running fine for months, and now this.

When I click on Draw Text from either the T icon or the menu, I get the exception window below.
Just prior to this session, I had loaded the CamBam StickFonts into Windoze.  Ok, I uninstalled them, same issue.
Well, then I uninstalled the 64bit version and loaded the 32bit, and it throws the same exception, still no StickFonts installed.
Next step, uninstall CamBam, go through the Windows files and clear out the left over files from the removals, reboot, install the 32bit version 1.0.  Same exception.

Any thoughts?
« Last Edit: October 12, 2020, 14:43:47 pm by llamatrails »


Offline EddyCurrent

  • CNC Jedi
  • *****
  • Posts: 4645
    • View Profile
Re: Crash when Draw Text is selected
« Reply #1 on: October 12, 2020, 06:44:13 am »
Was there a Windows update ? what version of Windows are you on now 1909 or 2004 or 20H2  ?

When you reinstalled CamBam did you remove all plugins other than the default CamBam ones ?

Is it the same issue as this ?

« Last Edit: October 12, 2020, 06:59:39 am by EddyCurrent »
Made in England

Offline llamatrails

  • Ewok
  • *
  • Posts: 49
    • View Profile
Re: Crash when Draw Text is selected - Solved !!!
« Reply #2 on: October 12, 2020, 14:37:26 pm »
Windows 10 Pro, version 1909, M$ says my system isn't ready to be upgraded  to 2004 yet ...
Haven't used CamBam in a while so there have been a few Windoze updates and I haven't used Draw Text in a very long time.
When I reinstalled CamBam, it was after deleting all the leftover files, folders and plugins from the removal and no additional plugins were added, just what the .msi file installed.  Haven't added back in the StickFonts yet.

Ok, problem now solved per the above link.  For anyone else that runs into this, here are the steps:
The following solution is a workaround until Microsoft fixes the issue with an update.

To perform the following steps, you need to have administrator rights on your computer.

Close all open documents and programs on your computer.
Press the Windows key.
Type Settings.
Select Time & Language.
Click Language.
Under Related settings, click Administrative language settings.
On the Region window, click the Administrative tab.
Click Change system locale. Here you will need administrator rights.
Clear the Beta: Use Unicode UTF-8 for worldwide language support checkbox.
Click OK.
Restart your computer.

Thanks for the quick reply and solution !!!