Author Topic: Gerber Import Issue - unexpected move format  (Read 199 times)

Offline CScotty

  • Ewok
  • *
  • Posts: 37
    • View Profile
Gerber Import Issue - unexpected move format
« on: December 19, 2020, 21:05:26 pm »
In my Gerber viewer things look correct.  Importing to Cambam 1.0 has parts missing along with the message "unexpected move format".  There doesn't seem to be log file or anything to help me tie the error message to a specific line so I don't know if the error is in the Gerber or the import.

Images and Gerber attached.

Any ideas?
-CS




Offline Dragonfly

  • CNC Jedi
  • *****
  • Posts: 2420
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #1 on: December 20, 2020, 08:57:06 am »
Perhaps it's related to Gerber version. Gerber files I export (from DipTrace) open correctly and I haven't looked deeper into what version it uses. There are 2 export options: Gerber and Gerber X2. I always select Gerber .

Offline CScotty

  • Ewok
  • *
  • Posts: 37
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #2 on: December 20, 2020, 12:25:58 pm »
I just tried using X2 but that has not helped. 

I've used the Gerber import many times in the past but this is the first time I've had this issue.

I just tested the Gerber on the reference viewer and no error there https://gerber-viewer.ucamco.com/


« Last Edit: December 20, 2020, 13:27:15 pm by CScotty »

Offline Dragonfly

  • CNC Jedi
  • *****
  • Posts: 2420
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #3 on: December 20, 2020, 17:08:41 pm »
Something must have changed nevertheless in the meantime. PCB program, CB plugin, OS ...

Offline CScotty

  • Ewok
  • *
  • Posts: 37
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #4 on: December 20, 2020, 17:51:32 pm »
Well the file is different, of necessity. If I remove the copper pour, I can work around the issue, sort of.

Can someone please try the supplied file on their system to see if they can reproduce the issue?

Offline Dragonfly

  • CNC Jedi
  • *****
  • Posts: 2420
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #5 on: December 20, 2020, 19:18:21 pm »
Ah, I didn't see the file attached.
Same error trying to open it here. Unfortunately.

Offline Dragonfly

  • CNC Jedi
  • *****
  • Posts: 2420
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #6 on: December 20, 2020, 19:22:42 pm »
Try changing the thermal settings and bridges settings, as well as the copper pour distance from the tracks.
What PCB CAD program are you using?

Offline CScotty

  • Ewok
  • *
  • Posts: 37
    • View Profile
Re: Gerber Import Issue - unexpected move format
« Reply #7 on: December 20, 2020, 19:35:54 pm »
I have tried that, even to the point of having no relief at all (not really practical).  It just moves the problem to a new location. Certainly reliefs seem to be the thing that is causing Cambam difficulty.

I'm using Kicad 5.1.8.
Win 10 76 bit
Cambam1.0 plus

PS: I wonder if there is a limit to the number of points in a poinlist?  The pour has over 1262 points

PPS: I've noe tested on three different computers. Two with Win 10 x64 and one Win 7 x32. Same problem in all cases.
« Last Edit: December 22, 2020, 12:12:54 pm by CScotty »